Привет!
Есть программеры что–либо писавшие под s60?
Посоветуйте каких–нибудь книжек или форумов. Идеально конечно было бы что–то вроде видеоуроков с рассказом про ядро, библиотеки и прочее. Интересует только с++.
Поставил карбид, поставил СДК, вся эта кухня вроде–бы работает (запускается, на эмуляторе сэмплы работают). Хочу попробовать что–нибудь портировать под s60 с WM5. Проблема в том, что сэмплы которые есть в карбиде (даже простейшие) на первый взгляд перегружены какой–то непонятной и ненужной фигнёй. При этом, хочется узнать какие сервисы есть у ОС (что–то типа трея, итп).
Сэмплы, уроки, книжки, наставления приветствуются.

Tagged with:
 

5 Responses to Привет!

  1. I:

    Более конкретный вопрос
    Нашел рассказку: My first application — Qt for Symbian
    Qt установлен, в Carbide пути к Qt настроены, стоит 3 SDK, какие–то плагины (хз что это и зачем)
    При попытке сделать проект с Qt (так–же как в рассказке) в окне выбора Build Targets если стоит галочка «Filter build configuration that doesn’t contain Qt support» то нельзя выбрать ни один таргет и оно пишет «No SDK’s were found that contain Qt support». Поиск в web’е пока ничего не дал. Если фильтр снять и всё–таки создать проект, то с ним не получается ничего сделать т.к. оно постоянно орёт про какую–то java exception (list index out of bounds).

    И ещё у меня из консоли не запускается «devices» — пишет «Can’t open perl script «\Program»: No such file or directory». Я понимаю что там пробел в пути. Как найти скрипт, который пытается туда обратиться или как найти то, куда он пытается обратиться?

  2. I:

    первый вопрос снят. Помогло «SDKs will only show as having Qt support when you’ve successfully installed the Qt libraries for the target to them and/or built Qt for the Windows emulator using them.» и ссылка.

  3. I:

    второй вопрос снят. из консоли qt работает нормально (как ни странно)

  4. EIna:

    Учил методом тыка. Хороших книжек на русском нет. Горнакова не читай — шлак.

    //snippets.dzone.com/tag/series60
    //www.mobi.ru/RubricatorS.php?r_id=…

  5. I:

    угу, спасибо. я тут кстати пытался карбид обновить стандартным способом с 2.0.4 до 2.1.0 и что–то видимо пошло не так (хотя ни на что не ругался в процессе) и теперь он всё ещё 2.0.4 но меню help–>update более не работает (пишет про ошибки конфигурации).
    Плюс, у меня так тот пример и не заработал т.к. Java ругается на exception’ы при попытке что–либо сделать с Qt–вкладками. Видимо, надо «перегрузить холодильник» и попробовать снова.

Добавить комментарий